Using the Main Window

Help > Main Window > Using the Main Window

When you start Shine, it’ll load up and then you’ll be presented with the Main Window. This is the window where you’ll see your events, and all the buttons and tools you need, in order to do things like make new events, view a different day or month, or search for an event.

The main window, in pretty much all cases, is your starting point for doing anything in Shine. So, this being the window you’ll be interacting with a lot, you may as well get comfortable with it.

The main window is divided up into a number of sections. I’ll list the sections here, and we’ll delve a bit more into the details down below:

 

  1. The title bar
  2. The menu bar
  3. The toolbar
  4. The calendar view
  5. The sidebar
  6. The date bar
  7. The status bar

So, now that we know the names of things, let’s look at what they are:

The Title Bar

The title bar is at the top of (almost) every window out there. This is usually where you’ll find the name of the program you’re using or the document you’re working on. Along with that, you’ll find buttons for interacting with the window (i.e. minimize, maximize, close). On Windows, these buttons are usually called the caption buttons.

Although many title bars look pretty much the same, some programs decide to create custom title bars, such as Microsoft Office, Google Chrome, and Shine. For Shine, the biggest difference with its title bar is the inclusion of the “Options” and “Help” menus near the caption buttons. For more information about the menu items in the Options menu, see the Options Menu page. For the Help menu, see the Help Menu command reference.

At all times, the title bar is visible in a program. And for Shine, this means the Options and Help menus are always visible as well.

The Menu Bar

The Menu Bar is the location from which every command available in Shine can be accessed. The menu bar acts like pretty much any other menu bar you’ve used in other programs.

For more information about the commands on the menu bar, see the Menu Command Reference.

By default, the menu bar is hidden when you first start up Shine. Most users will be okay without using the menu bar – the commonly used functions are available through other ways. For users who want access to the menu bar temporarily, it can always be selected by pressing the Alt key. If you want access to it all the time, you can select Options > Show menu bar or View > Show menu bar.

The Toolbar

The toolbar displays a horizontal list of buttons, each one tied to a command and always available, just a single click away. Toolbar buttons can call commands such as creating new events, changing to Week view, or opening or closing the Sidebar.

You’re able to customize the toolbar and choose which buttons you want and don’t want on it. It’s recommended to put on buttons for the commands you use most often or commands that you want to easily access. Learn more about customizing the toolbar at the Customize Toolbar page.

The toolbar is displayed at the top of the window (beneath the menu bar), but it can be moved down to the bottom of the window, or hidden altogether. This can be accessed through the Options or View menus.

The Calendar View

The calendar view area is where you’ll actually see your calendars and the events in them. The calendar view can be laid out in one of multiple ways, depending upon how you want to view your events, such as Month view, Week view, or Agenda view. This section is basically what makes a calendar app what it is.

This takes up the largest part of the window so you have the most space to be able to view your calendars and the events in it. Depending upon the view, there are a number of ways to customize it, which you can do through the Options window (Options > More options) in the Interface pane.

The calendar view area cannot be hidden or moved. It’s the essential part of any calendar program, so it would be a bit weird if it could be hidden away.

The Sidebar

The sidebar is where you can find an always-current list of all the calendars you have connected to Shine, and be able to show or hide them as you feel like it. The sidebar can also display your list of tasks to do.

By default, the sidebar is shown on the left side of the window. It can be moved to the right side, or hidden altogether. This can be accessed through the Options or View menu.

The Date Bar

The date bar allows you quick and easy access to the dates/weeks/months/etc. next to the one you’re currently viewing. For example, if you’re currently looking at January 2018, you can quickly jump to December 2017 or February 2018 using the date bar. If the window is wide enough, you’ll be able to see even more months to quickly jump to in the date bar.

By default, the date bar is shown at the bottom of the window. You can hide it by selecting View > Show date bar.

The Status Bar

The status bar will appear from time to time while Shine is doing something that will take some time, such as loading in your online calendars. In general, it shouldn’t take too long to complete whatever needs to be done, so you should only see the status bar for a little while. It hides itself when there isn’t anything to show.

The status bar will only be displayed during time-consuming actions. This currently cannot be customized.